Performance Issues for some customers

Incident Report for Brillium

Postmortem

Select customers experienced a brief service interruption due to abnormal external activity. The team addressed the issue promptly, and normal service was restored.

We are continuing to strengthen our monitoring and protective controls to further improve platform resilience.

Posted Mar 26, 2026 - 11:27 EDT

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 11:07 EDT

Update

We are continuing to monitor for any further issues.
Posted Mar 26, 2026 - 08:16 EDT

Update

We are continuing to monitor for any further issues.
Posted Mar 26, 2026 - 08:15 EDT

Monitoring

Affected customer are operating normally. We are continuing to monitor status.
Posted Mar 26, 2026 - 08:08 EDT

Update

Affected customers should see normal operation in the next few moments.
Posted Mar 26, 2026 - 08:00 EDT

Investigating

We are investigating performance issues reported for some customers. Access may be briefly interrupted for affected customers.
Posted Mar 26, 2026 - 07:30 EDT
This incident affected: API & Integrations (API, Zapier Integration), Administration (User Administration and Authentication), and Assessment Builder (Assessment Authoring, Assessment Delivery).