Assessment Builder application degraded performance

Incident Report for Brillium

Postmortem

Our investigation revealed that at approxiamately 2025-09-23T12:29:10Z (UTC) we experienced a temporary service disruption caused by an unexpected and extreme surge in network traffic. At peak, our systems were servicing over 20,000 simultaneous requests per second, which impacted Application Builder performance for a significant segment of our customers. Initial analysis of our Application Firewall (AF) logs shows that requests were valid and there is no indication of malicious activity.

Our System Operations team reviewed and refreshed affected systems to restore system services performance and availability.

We will continue to investigate the root cause data and apply additional operational enhancements aimed at improving the platform’s ability to handle unusual activity of this nature.

Posted Sep 23, 2025 - 13:30 EDT

Resolved

All systems have returned to normal operational performance.
Posted Sep 23, 2025 - 13:25 EDT

Monitoring

All systems are available and operating as expected. We will be monitoring systems closely during the next few hours to ensure system operations are performing as expected.
Posted Sep 23, 2025 - 12:13 EDT

Identified

The systems operations team will be performing a systems refresh. This should take about 15 minutes. During this time, there may be limited access to brillium Assessment Builder.
Posted Sep 23, 2025 - 11:48 EDT

Update

We are currently validating our investigation findings.
Posted Sep 23, 2025 - 11:17 EDT

Update

We are investigating degraded performance with Assessment Builder. Other applications appear to be unaffected.
Posted Sep 23, 2025 - 09:57 EDT

Investigating

We are currently investigating this issue.
Posted Sep 23, 2025 - 09:42 EDT
This incident affected: Assessment Builder (Assessment Authoring, Assessment Delivery).